4.0-624 5 years, 9 months ago PixelShaderGen: Perform some of the fog calculations with integers.
4.0-623 5 years, 9 months ago fixup! ce5e0f304fcdf85e0d6ee42a03b1270379b7bcc9
4.0-622 5 years, 9 months ago PixelShaderGen: Use integer math for z textures.
4.0-621 5 years, 9 months ago PixelShaderGen: Define idot for int4 vectors, too.
4.0-620 5 years, 9 months ago PixelShaderGen: Treat UV coordinates like S17.7 integers (they're still stored as float, though).
4.0-619 5 years, 9 months ago Fix LightingShaderGen multiplying by wrong types.
4.0-618 5 years, 9 months ago LightingShaderGen: Perform more lighting calculations with integers.
4.0-617 5 years, 9 months ago LightingShaderGen: Perform some lighting calculations with integers.
4.0-616 5 years, 9 months ago ShaderGen: Store material uniforms as integers.
4.0-615 5 years, 9 months ago ShaderGen: Store light color uniforms as integers.
4.0-614 5 years, 9 months ago PixelShader: Store fog color as an integer.
4.0-613 5 years, 9 months ago PixelShaderGen: Change indirect texture matrix uniforms to use integers.
4.0-612 5 years, 9 months ago PixelShaderGen: Change the "alpha" uniform to use integers.
4.0-611 5 years, 9 months ago PixelShaderGen: Change the "colors" and "kcolors" uniforms to be integers.
4.0-610 5 years, 9 months ago PixelShaderGen: Process fog calculations with integer math.
4.0-609 5 years, 9 months ago Provide our own dot functions in GLSL since GLSL doesn't provide integer versions of this function, even though AMD and Nvidia provide their own.
4.0-608 5 years, 9 months ago PixelShaderGen: Microsoft's shader compiler likes to throw an internal error when masking with unsigned integers, so just use 255 instead of 0xFF all over the place...
4.0-607 5 years, 9 months ago PixelShaderGen: Use integer math for indirect tev stage texcoord calculation.
4.0-606 5 years, 9 months ago PixelShaderGen: prev should be initialized to the proper value; tev output needs to be clamped between -1024 and 1023.
4.0-605 5 years, 9 months ago PixelShaderGen: Remove superfluous registerstate stuff. Also, made alphabump an integer. Things are working again!